上CentOS 5.1.x的PHP 5.3 5.6的升級PHP

不育系網站,包括 有安裝較新版本的最低要求 5.1.x pe 。 下面的教程將告訴你一些簡單的步驟,你可以 的PHP版本PHP 5.1 5.3.x的升級 pe 5.6.

1。 首先,你需要停止 Web服務器。 (httpd服務)

httpd服務站

2。 清除5.1.x安裝在服務器上的PHP軟件包。

百勝刪除PHP PHP *

3。 在您收到確認PHP軟件包從服務器上刪除,去安裝包 PHP 5.3的.

yum安裝php53.i386
yum安裝bcmath.i53 php386
yum安裝php53-cli.i386
yum安裝php53-common.i386
yum安裝php53-dba.i386
yum安裝devel.i53 php386
yum安裝php53-gd.i386
yum安裝imap.i53 php386
yum安裝php53-intl.i386
百勝安裝php53,ldap.i386
yum安裝mbstring.i53 php386
yum安裝mysql.i53 php386
yum安裝php53-odbc.i386
yum安裝php53-pdo.i386
yum安裝pgsql.i53 php386
yum安裝process.i53 php386
yum安裝pspell.i53 php386
yum安裝php53-snmp.i386
yum安裝soap.i53 php386
yum安裝xml.i53 php386
yum安裝xmlrpc.i53 php386

或者更簡單地說,安裝所有包php53 *。

安裝php53 *

4。 啟動Apache Web服務器

服務的httpd啟動

套餐 php53梨, php53 mcrypt的, php53哈稀, php53-ODP, php53 PECL-APC si php53-PECL memcache的 不適用於CentOS 5.6的。

最後檢查的PHP5.3版本已經安裝成功。 創建一個PHP(如info.php的。):

<?PHP的

phpinfo()函數;

的phpinfo(INFO_MODULES);

?>

爬在Firefox的地址服務器和訪問文件, , 或任何其他網絡瀏覽器。 結果應該是:

PHP信息

你可以看到哪個版本的PHP安裝在服務器和命令行: 運行php-v百勝列表| grep的PHP安裝“(會顯示所有安裝PHP軟件包)。

百勝安裝了PHP列表

- 升級/安裝PHP在CentOS 5.3的5.6.

上CentOS 5.1.x的PHP 5.3 5.6的升級PHP

關於作者

隱形LP

創始人兼編輯 隱身設置在2006日期。
具有Linux操作系統(尤其是CentOS),Mac OS X, Windows XP> Windows 10和WordPress(CMS)。

發表評論