修復問題:您的服務器運行的是 PHP 版本 5.1.6 但 WordPress 3.2.1 至少需要 5.2.4。

通知所有不為人所熟知,對於 安裝 或者做 升級新版本 3.2這是必要的 安裝了新版本 5.2.4.

如果服務器是安裝一個的PHP的比5.2.4舊版本,安裝版本 WordPress 3.2.1會出現 錯誤 /消息:您的服務器正在運行 PHP 5.1.6 版,但 WordPress 3.2.1 至少需要 5.2.4“。
非常簡單地解決這個問題可以通過升級PHP,但在這樣做之前,應該考慮幾件事情。 首先,請升級 PHP是一個共享的主機. 要升級,您必須有權訪問 administrator 在服務器上(專用服務器VPS)。 第二,在升級之前,應當記錄,並意識到 新版本的PHP 為了不給 錯誤該服務器上的其他網站.

對於 運作系統是用於 Web服務器 (Agreart和 / 南國)會告訴你該怎麼辦 升級到PHP CentOS 5.2.10.x的5 32位的.

升級PHP在CentOS 5.1.x的5.2.x的到5.x 32位

1。 檢查封裝/模塊安裝PHP(例如PHP mcrypt的)的,除了標準包。 如果存在,將被刪除或actuzlizate。

檢查已安裝的軟件包:

rpm -qa | grep php
old_php_version

2。 要添加額外的存儲庫 需要 升級的PHP版本。

nano /etc/yum.repos.d/CentOS-Testing.repo

新的文件(CentOS的Testing.repo的)將添加以下行(複製/粘貼):

[c5-testing] 
name=CentOS-5 Testing 
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/ 
enabled=1 
gpgcheck=1 
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing 
includepkgs=php*

Ctrl + X. 保存的文件CentOS的Testing.repo的。

3. Update PHP 通過 yum:

yum update

4. Restart / httpd的 :

service httpd restart

後 restart httpd檢查版本和安裝的軟件包:

new_php_version

檢查模塊/包的錯誤:

php -v

- PHP升級/ CentOS 32的位(i386).

創始人兼編輯 Stealth Settings,從2006年至今。 具有Linux操作系統(尤其是CentOS)方面的經驗, Mac OS X, Windows XP> Windows 10 si WordPress (內容管理系統)。

發表評論